Forum

Replies

  • PRO
    Ian, I'd guess attachment is not engaging properly before you tighten t bar. The female end in the power unit had little ramps built in to try and make the attachment engage in any orientation but doesn't always work.

    You try blipping throttle or manually turning attachment so the my mesh.

    You do get used to it.... :)
  • PRO
    One thing to check is that the head of the unit is actually attached to the shaft properly at the head end? Other than that it's as Gary has said... good luck
    • Took top off and re tightened seems fine now
  • PRO Supplier

    are the grey plastic inserts worn? Sit power unit vertically and push the attachment down firmly so it fully engages...its probably because its so new...not locating properly, as GRK said......I had the opposite problem, too much use caused a slack shaft..(no sniggering)...

    • PRO
      You need your shaft 'nip & tucked' then or a new 'end' ..... :D
  • PRO
    I bought some extra pins just in case for repair on the run
This reply was deleted.

Landscape industry Jobs

Gardener – Oxford Lawns and Gardens Ltd

Employer: Oxford Lawns and Gardens Ltd

Job Type: Full Time

Location: oxfordshire

Full time and Part time position for gardeners to join an expanding Company.  Oxford Lawns and Gardens specialise in the… Continue

Garden maintenance team leader

Employer: Garden Force

Job Type: Full Time

Location: guildford

. We require a full or part-time supervisor  for an established garden maintenance round in the  Guildford area. You will be required to drive… Continue

Latest blog post

Trade green waste centres

Start a landscaping business

LJN Sponsor

Advertising

Technical landscaping books

Blogs

PRO Supplier

Wycliffe Bowls Club head greenkeeper Keith Freakley and his assistant Raymond John Carter have both praised their recently purchased Dennis Razor Ultra 560 for its ease of operation.

For the past six years, Keith has been looking after…

Read more…